viff

changeset 973:44f0a5053a4e

Removed ConfigObj installation instructions.
author Martin Geisler <mg@daimi.au.dk>
date Wed, 08 Oct 2008 21:11:40 +0200
parents dda8de7d13a2
children 37f9eed3e51f
files doc/install.txt
diffstat 1 files changed, 11 insertions(+), 26 deletions(-) [+]
line diff
     1.1 --- a/doc/install.txt	Wed Oct 08 21:07:42 2008 +0200
     1.2 +++ b/doc/install.txt	Wed Oct 08 21:11:40 2008 +0200
     1.3 @@ -6,14 +6,13 @@
     1.4  
     1.5  VIFF is written in Python and uses the Twisted framework for
     1.6  asynchronous communication, (optionally) OpenSSL and PyOpenSSL for
     1.7 -secure communication, ConfigObj for configuration files, and GMPY for
     1.8 -fast bignum arithmetic. You can find these components here:
     1.9 +secure communication, and GMPY for fast bignum arithmetic. You can
    1.10 +find these components here:
    1.11  
    1.12  :Python:         http://python.org/
    1.13  :Twisted:        http://twistedmatrix.com/
    1.14  :OpenSSL:        http://www.openssl.org/
    1.15  :PyOpenSSL:      http://pyopenssl.sourceforge.net/
    1.16 -:ConfigObj:      http://voidspace.org.uk/python/configobj.html
    1.17  :GMPY:           http://code.google.com/p/gmpy/
    1.18  
    1.19  VIFF has been successfully tested with the following versions:
    1.20 @@ -22,7 +21,6 @@
    1.21  :Twisted:        2.5 to 8.1.0
    1.22  :OpenSSL:        0.9.8g
    1.23  :PyOpenSSL:      0.7
    1.24 -:ConfigObj:      4.4.0
    1.25  :GMPY:           1.0alpha to 1.0.2
    1.26  
    1.27  Please `report back`_ if you find that VIFF works with other versions
    1.28 @@ -49,27 +47,21 @@
    1.29  
    1.30  3) Download and install Twisted_.
    1.31  
    1.32 -4) Download ConfigObj_ and enter::
    1.33 -
    1.34 -      python setup.py install
    1.35 -
    1.36 -   from the folder where you unzipped the files.
    1.37 -
    1.38 -5) Download and install GMPY_. If you are using Vista, right-click on
    1.39 +4) Download and install GMPY_. If you are using Vista, right-click on
    1.40     the installer and choose the option to run as administrator.
    1.41  
    1.42 -6) Download and execute an `OpenSSL Win32 Installer`_. Problems have
    1.43 +5) Download and execute an `OpenSSL Win32 Installer`_. Problems have
    1.44     been reported when using the latest release, 0.9.8h, so currently
    1.45     0.9.8g is recommended.
    1.46  
    1.47 -7) Download and install PyOpenSSL_. Again, run the installer as
    1.48 +6) Download and install PyOpenSSL_. Again, run the installer as
    1.49     administrator if you are using Vista.
    1.50  
    1.51 -8) Download and install VIFF_. Note that if you are using the
    1.52 +7) Download and install VIFF_. Note that if you are using the
    1.53     installer on Vista, you will again need to run it as an
    1.54     administrator.
    1.55  
    1.56 -9) Proceed to `testing`_.
    1.57 +8) Proceed to `testing`_.
    1.58  
    1.59  
    1.60  Mac OS X
    1.61 @@ -90,23 +82,17 @@
    1.62  
    1.63  3) Optionally: download PyOpenSSL_ and tell us if it works!
    1.64  
    1.65 -4) Download ConfigObj_ and enter::
    1.66 -
    1.67 -      python setup.py install
    1.68 -
    1.69 -   from the folder where you unzipped the files.
    1.70 -
    1.71 -5) Download and install GMPY_ following the instructions in
    1.72 +4) Download and install GMPY_ following the instructions in
    1.73     ``gmpy-1.02.macosx.README.txt`` (under Downloads).
    1.74  
    1.75 -6) Install VIFF from source (see below). If you prefer you can just
    1.76 +5) Install VIFF from source (see below). If you prefer you can just
    1.77     install it in site-packages, it makes no difference. For
    1.78     developers, it is perhaps a better solution in to create a symbolic
    1.79     link from the site-packages directory to the VIFF Python files
    1.80     (``viff/viff/``), as otherwise you need to re-install VIFF each time
    1.81     the project is modified.
    1.82  
    1.83 -7) Proceed to `testing`_.
    1.84 +6) Proceed to `testing`_.
    1.85  
    1.86  
    1.87  GNU/Linux
    1.88 @@ -125,7 +111,7 @@
    1.89    You can install all dependencies by the command::
    1.90  
    1.91       aptitude install python-twisted-core python-pyopenssl \
    1.92 -                      python-configobj python-gmpy
    1.93 +                      python-gmpy
    1.94  
    1.95    The backslash indicates that both lines should be typed as a single
    1.96    line in the terminal.
    1.97 @@ -240,7 +226,6 @@
    1.98  .. _test VIFF: http://buildbot.viff.dk/
    1.99  .. _Python: http://python.org/
   1.100  .. _Twisted: http://twistedmatrix.com/
   1.101 -.. _ConfigObj: http://voidspace.org.uk/python/configobj.html
   1.102  .. _GMPY: http://code.google.com/p/gmpy/
   1.103  .. _OpenSSL Win32 installer: http://www.slproweb.com/products/Win32OpenSSL.html
   1.104  .. _PyOpenSSL: http://pyopenssl.sourceforge.net/